sch4f

Hello!
I made a psd file with multiple skins to try the new feature with bone skins. Import went fine and I wanted to draw the skeleton. Normally I press ctrl and click the image I want to parent the bone to. In that case my image jumped to the center where the original root bone is located. I also tried parenting after drawing the bone and it happend again.

Then I updated from 3.8 to 3.8.57 and my problem was solved. it just worked. But now it occured again after I imported new assets to the skeleton with a json. I added a collar to the pets and when i tried to parent it to the neck bone it just jumped to the root bone again. restarting didnt change a thing.

I attached images of both incidents and a log for the second one.

Also i got a warning message that images where duplicates and not in a skin and they were deleted. i dont understand what happend here. I tried the new feature and added skin elements in my psd and exported a json. then imported it in my existing skeleton. until i saved and closed it everything worked out fine. then i got the warning message when i opened spine again.
can you help me?
Find the warning message also attached here.
thank you
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Benutzeravatar
sch4f
  • Beiträge: 14

Erikari

Hello! I tried to reproduce your problem on one of our projects but everything appeared to be working fine.
Could you perhaps provide the problematic files to our mail contact@esotericsoftware.com mentioning this topic?

It would be ideal to have a list of steps to follow to get the problem to happen, otherwise, I can try to click around hoping the problem will occur again :D
Benutzeravatar
Erikari

Erikari
  • Beiträge: 1872

sch4f

Thank you! I sent the files to the email adress and added the steps i do to cause the problem.
Benutzeravatar
sch4f
  • Beiträge: 14

Erikari

Thanks! I could reproduce the reparenting problem using your files, we're on it :D
Benutzeravatar
Erikari

Erikari
  • Beiträge: 1872

Nate

Thanks for the files! This has been fixed in 3.8.58. You'll get some warnings when you open the project the first time, that is Spine fixing things up. After saving, reopening should not show warnings.
Benutzeravatar
Nate

Nate
  • Beiträge: 9161

sch4f

Thank you very much! And I want to add that I'm super excited about the new features in spine 3.8 and that you guys make an incredible job <3 I use spine since 2015 and its my favorite animation software. also you make it more special with every update. thanks!
Benutzeravatar
sch4f
  • Beiträge: 14

Nate

Aww, thank you for the kind words! :happy:

3.8.58 is up now!
Benutzeravatar
Nate

Nate
  • Beiträge: 9161


Zurück zu Bugs