PageIGT

Upon, adding the Timeline Extension (4.1 or 4.0) for a Unity 2018.4 project an invalid dependencies error is given: "...invalid dependencies: com.unity.timeline: Resolved version [1.0.0] does not satisfy requested version [1.2.10]"

So it appears that the Timeline Extension has a dependency requiring Timeline to be 1.2.10 or higher. The Timeline in 2018.4 is version 1.0.0.

2 issues that make it more troublesome:
1. Seems like the Timeline in Unity 2018 is embedded rather then using a package, as seen in Unity 2020 for example.
2. Testing adding a Timeline package to 2018.4 regardless of the embedded nature, but it looks like the Unity timeline 1.2 package is for 2019.3 + and doesn't work in 2018.4.

The question is, what could be a possible solution for adding the Spine Timeline extension (for either Spine-Unity 4.0 or 4.1) to Unity 2018.4?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
PageIGT
  • Beiträge: 2

Harald

We're sorry for the troubles! You can use the latest Spine 4.1 timeline package with older Unity versions as well, please just unpack the zip package (e.g. com.esotericsoftware.spine.timeline-4.1-2022-08-26.zip) anywhere in your Assets folder. This way it ignores the package.json file and does not try to resolve any dependencies.
Benutzeravatar
Harald

Harri
  • Beiträge: 4335

PageIGT

Thanks Harald. Nice and easy solution. It works great using 4.1. Appreciate your expertise!
PageIGT
  • Beiträge: 2

Harald

Glad to hear it helped, thanks for getting back to us!
Benutzeravatar
Harald

Harri
  • Beiträge: 4335


Zurück zu Runtimes