mbi

Editor and Preview, sequence with different sized images
The spine editor 4.1.09 will hit an infinite dialog opening loop when changing a sequence from region to mesh if images in sequence does not all have the exact same image size. It seems to be connected to the preview window. And can be triggered by playing the animation in the previewer.



Running an animation with a sequence which has images of different sizes, has a side effect of flashing the image size differences in the animation window.




My question?
How is the sequence feature meant to be used?

The editor has different behavior for sequences (with images of different sizes) if the sequence is a region or a mesh.

If the sequence is a mesh and the sequence consists of different sized images, the editor will show the entire sequence as being the same size. Effectively changing the resolution while keeping the size the same.

However if the sequence is a region and the sequence consists of different sized images, the editor will show the size differences sequence as being the same size.

JSON Export
The json export does not contain information about the size of the individual images in a sequence. Which makes it a bit hard for us to throw an error if all the images in a sequence does not have the same size.

Further more the size exported to the json seem to be from the last image in the sequence.
"sequence": {
"images/sequence/sequence_": {
"width": 1000,
"height": 250,
"sequence": { "count": 21, "start": 0, "digits": 5 }
}
},
"not_sequence": {
"images/image": { "x": 0.5, "width": 127, "height": 26 }
}
So how is the sequence feature meant to be used?

Are different sized images in a sequence not supposed to be supported?

Should it work like mesh, where images size result in resolution change?
or region where image size result in a visual size change in the sequence animation.

Being able to have images in different sizes could optimise space consumption in sprite maps etc, but is hard to use in practice since all images in the sequence have the same anchor point and can not have individual transform offset...
mbi
  • Beiträge: 2

Misaki

Sorry for the trouble. That is certainly an issue we need to fix, so I have created an issue ticket here:
https://github.com/EsotericSoftware/spine-editor/issues/705

Let me summarize the current specifications. If a sequence attachment does not use mesh, it does not matter if each image has a different size. This can be confirmed using the Spineboy's muzzle effect images:


However, if the mesh checkbox is enabled, a dialog appear when a frame using the different size image is displayed, and it occurs infinitely even if you confirm the warning with the all frames:


I am afraid I have not answered all of your questions, but please wait until Nate confirms the details.
Benutzeravatar
Misaki

Misaki
  • Beiträge: 1026

mbi

Thanks for the snappy answer.

Please do let me know when you have had time to look into the other issues and questions.

Furthermore when trying to replicate your spineboy example, we experience inconsistencies with the "Frame" field in the sequence settings. Sometimes with a region sequence it appears to be greyed out and cannot be edited... is this somehow intentional or a bug?

spineboy region sequence.png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
mbi
  • Beiträge: 2

Nate

Frame being disabled was a bug. Thanks for letting us know! We've fixed it in 4.1.10, available soon.
Benutzeravatar
Nate

Nate
  • Beiträge: 12136

Misaki

@mbi The issue #705 is also fixed in 4.1.10, which we'll release today. Nate has commented on the issue ticket on GitHub with a detailed explanation:
https://github.com/EsotericSoftware/spine-editor/issues/705
Benutzeravatar
Misaki

Misaki
  • Beiträge: 1026


Zurück zu Bugs