Norsevidur

Well I seem to be a master at generating errors in Spine.
After updating to the newest version of Spine im unable to export as .json.

I keep getting the error "an error occurred while exporting", and the spine log says "ERROR: Unable to export:
java.lang.RuntimeException: java.lang.RuntimeException: Skin not found in skeleton: default".

I have no idea how to set the default skin, and im unable to find any answers on Google or the forums.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Norsevidur
  • Beiträge: 7

jayn

I'm having the same error with 3.8.56 exporting files. When I export in previous version 3.8.55 it works perfectly fine.
jayn
  • Beiträge: 41

maple_mop

I'm getting the same. Seems like it's impossible to create a default skin, if you try to you get an error saying that the name 'default' is reserved.
maple_mop
  • Beiträge: 4

jzela

Same problem here.
jzela
  • Beiträge: 39

Nate

Sorry, we've got a fix in 3.8.57 and we'll get it uploaded ASAP.

---

3.8.57 is now up with the fix! Sorry again.

Please note there is a separate problem in the Spine Runtimes for skeletons that don't have any attachments in the default skin -- in other words, for skeletons that have all attachments in skins. The fix has been made in the reference implementation, spine-libgdx, and will be ported to all the other runtimes first thing in the morning. Sorry for the trouble!
Benutzeravatar
Nate

Nate
  • Beiträge: 9161

tikitantrum

Thank you!!!!
tikitantrum
  • Beiträge: 6

badlogic

This is now fixed for all runtimes.
Benutzeravatar
badlogic

Mario
  • Beiträge: 1924

Norsevidur

Thank you very much, Nate! Awesome and quick :)
Norsevidur
  • Beiträge: 7


Zurück zu Bugs