mcolombo

Hi,

I updated spine to spine-unity-3.8-2019-08-20 and now al kind of errors are showing on my editor.
Which also created the problem of not being able to see the SpineAnimation script.

Im using Unity 2019.2.2f1. I also exported the spines using 3.8

I get these errors (in the editor only, if y run the game, spine works):
InvalidCastException: Specified cast is not valid.
Spine.Unity.Editor.SpineEditorUtilities.IssueWarningsForUnrecommendedTextureSettings (System.String texturePath) (at Assets/Spine/Editor/spine-unity/Editor/Utility/SpineEditorUtilities.cs:172)
NullReferenceException: Object reference not set to an instance of an object
Spine.Unity.Editor.SpineInspectorUtility.PropertyFieldFitLabel (UnityEditor.SerializedProperty property, UnityEngine.GUIContent label, System.Single extraSpace) (at Assets/Spine/Editor/spine-unity/Editor/Utility/SpineInspectorUtility.cs:66)


And my SkeletonAnimation script looks like the one attached.

Anybody encountered this error? Im going nuts.

Thanks
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
mcolombo
  • Beiträge: 5

Harald

We are sorry for the inconvenience! We are currently improving the error messages and warnings in this regard to make it more obvious what is going wrong.

Please note that the Spine-Unity runtime version (e.g. 3.8 ) has to match the Spine Editor version (e.g. 3.8.68) which was used to export your skeleton files. When major+minor version numbers do not match (3.7 vs 3.8 ), import in Unity will fail due to format incompatibility.

Note that you can change the Spine Editor version via Spine - Settings:
Settings - Spine User Guide: Version
You can use batch-export to re-export all your skeletons quickly via the command line interface:
Export - Spine User Guide: Command line

Please also be sure to follow the Spine 3.7 to 3.8 upgrade guide to save you potential troubles:
Spine-Unity 3.7 to 3.8 Upgrade Guide
Benutzeravatar
Harald

Harri
  • Beiträge: 1096


Zurück zu Bugs