titidatiti

In my project, the blink animation is made by switching the eyeball slot off, and switching the eyeslash on.
I use 30fps as the editor framerate, but the eyeslash disappears with a lag on 60fps or higher framerate due to the interpolation.

Close eye on frame 3:
spine_question_01.png


Open eye on frame 4:
spine_question_02.png


If the animation is playing slowly (simulation of high framerate):
Spine_Question_03.gif


The wrong effect due to the interpolation:
spine_question_04.png


Is there something like a step curve to improve this situation, to disable the slot immediately after current frame, instead of waiting until next frame? :think:

Thank you!
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Benutzeravatar
titidatiti
  • Beiträge: 37

Misaki

You can move the attachment key to between the frames like 3.01 by holding Shift key. Please see this page of the user guide for more information:
关键帧 - Spine用户指南: 时间轴位置
Benutzeravatar
Misaki

Misaki
  • Beiträge: 1026

titidatiti

Misaki hat geschrieben:You can move the attachment key to between the frames like 3.01 by holding Shift key. Please see this page of the user guide for more information:
关键帧 - Spine用户指南: 时间轴位置
What a clever way! :nerd:
Thank you!
Benutzeravatar
titidatiti
  • Beiträge: 37


Zurück zu Editor