pinguin

Hi

I already posted the problem in Discord.
If you have a Slot named with a german char like öäü and export it via cli on Windows the result looks like "name":"Körper"
But it should be Körper.

C:\Program Files\Spine\Spine.exe -i ./data-src/dog\dog.spine -m -o ./data/dog/ -e ./data-src/spine_export_template.export.json
Spine 4.1.08 PRO and Launcher 4.0.34

Note: on Mac the same export looks fine.

Thx
Kolja
pinguin
  • Beiträge: 10

Nate

Spine writes JSON data using UTF-8. If you open a text file containing Körper in UTF-8 characters but the text editor displays ANSI characters, then you'll see Körper. I think the export is fine, it's just your text editor that is not interpreting the characters as UTF-8. I suggest Notepad++ on Windows, which allows you to choose the encoding:

Benutzeravatar
Nate

Nate
  • Beiträge: 12129

pinguin

Hi Nate,

I looked at the file with VS Code and it was set to UTF-8.
If I export via the UI the export looks right. Only the export via CLI creates a diff with the wrong encoding.

Do you need a spine file to reproduce it?

Kolja
pinguin
  • Beiträge: 10

Nate

Hmm, strange. The first thing to try is to download and reinstall Spine. Your 4.0.34 launcher is a bit old, the latest is 4.1.09 and it's possible that a new launcher fixes this kind of encoding error. If you still have the problem then the project file would help, you can email it to: contact@esotericsoftware.com
Benutzeravatar
Nate

Nate
  • Beiträge: 12129

pinguin

Hi Nate,

thanks for the tipp updating the launcher. I'm now on 4.1.09 and the encoding errors are gone.

Kolja

---

Hi,

I just found the bug. It was a problem in my python script that starts the spine exports.

Kolja
pinguin
  • Beiträge: 10


Zurück zu Editor