droptimal

Whenever our team exports, the Animations get duplicated 2 times. I'm using 3.8.36 and other have had the issue with various 3.8 versions.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
droptimal
  • Beiträge: 19

Erikari

Hello! Thanks for reporting the behavior, but we need more details for reproduction, could you please tell us what settings do you use to export?

---

The culprit appears to be Animation clean up

Repro steps:
1. open raptor
2. in setup mode, export a json, select animation clean up, export
3. go to animate mode
if that check is not selected, the problem does not occur

We're working on a fix, meanwhile, if you deselect that option it shouldn't cause that behavior.
Benutzeravatar
Erikari

Erikari
  • Beiträge: 2006

droptimal

To replicate: Export then toggle between Setup and Animation. When you toggle it will duplicate the animations.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
droptimal
  • Beiträge: 19

Nate

Thanks for the report! It has been fixed in 3.8.37-beta, available now. Cheers! :beer:
Benutzeravatar
Nate

Nate
  • Beiträge: 9284

droptimal

New version seems to work on my current file! However we opened some older files and upgraded to new patch and it broke the animations tree by hiding all the children. This issue is ONLY with these older files (created sometime around june). I tested these files in 3.8.11 and they worked fine. The current file I'm on was created within a week or two and doesn't suffer this issue when updated to 3.8.37
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
droptimal
  • Beiträge: 19

Nate

Yikes, that should not happen! We are able to open very old projects (eg 3.3.06) and the animations showed up. Could you email your .spine file so we can see what is going on? contact@esotericsoftware.com We don't need the images and will keep your file confidential.
Benutzeravatar
Nate

Nate
  • Beiträge: 9284


Zurück zu Bugs