steffan.weber

So when I export my spine animations from 3.8.14 and 3.8.13 the atlas is incredibly small, and doesn't contain all the assets I have used in the animation. I have to go back to 3.8.11 to get a decent export that will work.

I have tried doing tests with both 11 and 13/14, with different spine files, and restarting the software, and the only one that produces a valid export is 11.

Problem is that now I have updated to 14 and saved my file before I knew about this issue, so now I can't go back and export the same file on 11.

I really hope you have some sort of answer for this, because my project is sort of stalled until this is resolved.
steffan.weber
  • Beiträge: 13

Nate

Are you using polygonal packing?

You can try using Rectangles, however we would like to fix polygons if it is not working right. Maybe you can send the images you are packing so we can see the problem? contact@esotericsoftware.com
Benutzeravatar
Nate

Nate
  • Beiträge: 9284

Erikari

Regarding going back to a previous version of the file, Spine automatically saves backups, you can find the folder in the spine settings: Settings - Spine User Guide: Auto backup
Benutzeravatar
Erikari

Erikari
  • Beiträge: 2006

steffan.weber

sorry, forgot to mention, I'm exporting JSON. Trying to tell you as much detail as possible but a few things slipped.

Back up sounds nice, I did though do a lot of changes on .13, so I won't get that back with a .11 backup, I'm guessing.

where do I send the files?
steffan.weber
  • Beiträge: 13

Erikari

Please send the files mentioning this topic to contact@esotericsoftware.com
Benutzeravatar
Erikari

Erikari
  • Beiträge: 2006

steffan.weber

now we tried more than one license to export JSON on .14, and it doesn't work. we can't use the exported files at all. It even exports with no warnings or errors, but seems to be broken anyway.
steffan.weber
  • Beiträge: 13

Erikari

What is that is "broken"? Are you exporting for a specific runtime and it is not reading the new json format that was changed in 3.8.13? Is the runtime up to date to work with the current Spine version or does it require an older Spine export perhaps?
Benutzeravatar
Erikari

Erikari
  • Beiträge: 2006

badlogic

Note that the runtimes are being updated to support the new JSON format at the moment. We'll likely have that work finished by the end of the day for all runtimes.
Benutzeravatar
badlogic

Mario
  • Beiträge: 2099


Zurück zu Bugs